26a32845b5c1e5e768876a3da6bb8777d2cfcce4
[pkg-perl] / deb-src / libalien-wxwidgets-perl / libalien-wxwidgets-perl-0.50 / debian / rules
1 #!/usr/bin/make -f
2
3 export SBOX_REDIRECT_IGNORE:=/usr/bin/perl
4 unexport PERL5LIB
5 export PATH:=/usr/bin/dh7:/usr/bin:$(PATH)
6
7 # wxWidgets version
8 export V=`dpkg -s libwxgtk2.8-dev | grep ^Version |cut -f2 -d' '`
9 VMAJOR:=$(shell echo $(V) |cut -f 1 -d .)
10 VMINOR:=$(shell echo $(V) |cut -f 2 -d .)
11 VPATCH:=$(shell echo $(V) |cut -f 3 -d .)
12 NEXTPATCH:=$(shell expr $(VPATCH) + 1 2>/dev/null || expr `echo $(VPATCH) | cut -f 1 -d - ` + 1)
13
14 %:
15         dh --with quilt $@
16
17 override_dh_gencontrol:
18         echo 'wx:current=$(VMAJOR).$(VMINOR).$(VPATCH)~' \
19                 >> debian/libalien-wxwidgets-perl.substvars
20         echo 'wx:next=$(VMAJOR).$(VMINOR).$(NEXTPATCH)~' \
21                 >> debian/libalien-wxwidgets-perl.substvars
22         dh_gencontrol