e42332e9d8b0feaf84040d2ed48a69a247650394
[pkg-perl] / deb-src / libalien-wxwidgets-perl / libalien-wxwidgets-perl-0.50 / debian / rules
1 #!/usr/bin/make -f
2
3 export SBOX_REDIRECT_IGNORE:=/usr/bin/perl
4 unexport PERL5LIB
5 export PATH:=/usr/bin/dh7:/usr/bin:$(PATH)
6 export CPAN_SHELL_LEVEL=1
7
8 # wxWidgets version
9 export V=`dpkg -s libwxgtk2.8-dev | grep ^Version |cut -f2 -d' '`
10 VMAJOR:=$(shell echo $(V) |cut -f 1 -d .)
11 VMINOR:=$(shell echo $(V) |cut -f 2 -d .)
12 VPATCH:=$(shell echo $(V) |cut -f 3 -d .)
13 NEXTPATCH:=$(shell expr $(VPATCH) + 1 2>/dev/null || expr `echo $(VPATCH) | cut -f 1 -d - ` + 1)
14
15 %:
16         dh --with quilt $@
17
18 override_dh_install:
19         ./Build install --destdir debian/libalien-wxwidgets-perl
20         dh_install
21
22 override_dh_gencontrol:
23         echo 'wx:current=$(VMAJOR).$(VMINOR).$(VPATCH)~' \
24                 >> debian/libalien-wxwidgets-perl.substvars
25         echo 'wx:next=$(VMAJOR).$(VMINOR).$(NEXTPATCH)~' \
26                 >> debian/libalien-wxwidgets-perl.substvars
27         dh_gencontrol