Debian lenny version packages
[pkg-perl] / deb-src / libclass-accessor-perl / libclass-accessor-perl-0.31 / debian / patches / manpage_typo.diff
1 Index: libclass-accessor-perl/lib/Class/Accessor.pm
2 ===================================================================
3 --- libclass-accessor-perl.orig/lib/Class/Accessor.pm   2007-09-23 20:46:35.000000000 +0200
4 +++ libclass-accessor-perl/lib/Class/Accessor.pm        2007-09-23 20:50:22.000000000 +0200
5 @@ -55,7 +55,7 @@
6  One for each piece of data in your object.  While some will be unique,
7  doing value checks and special storage tricks, most will simply be
8  exercises in repetition.  Not only is it Bad Style to have a bunch of
9 -repetitious code, but its also simply not lazy, which is the real
10 +repetitious code, but it's also simply not lazy, which is the real
11  tragedy.
12  
13  If you make your module a subclass of Class::Accessor and declare your
14 @@ -233,8 +233,8 @@
15  it will throw an exception.  It only uses set() and not get().
16  
17  B<NOTE> I'm not entirely sure why this is useful, but I'm sure someone
18 -will need it.  If you've found a use, let me know.  Right now its here
19 -for orthoginality and because its easy to implement.
20 +will need it.  If you've found a use, let me know.  Right now it's here
21 +for orthoginality and because it's easy to implement.
22  
23      package Foo;
24      use base qw(Class::Accessor);
25 @@ -505,7 +505,7 @@
26  Direct hash access is, of course, much faster than all of these, but it
27  provides no encapsulation.
28  
29 -Of course, its not as simple as saying "Class::Accessor is slower than
30 +Of course, it's not as simple as saying "Class::Accessor is slower than
31  average".  These are benchmarks for a simple accessor.  If your accessors do
32  any sort of complicated work (such as talking to a database or writing to a
33  file) the time spent doing that work will quickly swamp the time spend just
34 @@ -611,7 +611,7 @@
35          return $self->SUPER::email(@_);
36      }
37  
38 -There's a subtle problem in the last example, and its in this line:
39 +There's a subtle problem in the last example, and it's in this line:
40  
41      return $self->SUPER::email(@_);
42  
43 Index: libclass-accessor-perl/README
44 ===================================================================
45 --- libclass-accessor-perl.orig/README  2007-09-23 20:48:38.000000000 +0200
46 +++ libclass-accessor-perl/README       2007-09-23 20:49:12.000000000 +0200
47 @@ -31,7 +31,7 @@
48      One for each piece of data in your object. While some will be unique,
49      doing value checks and special storage tricks, most will simply be
50      exercises in repetition. Not only is it Bad Style to have a bunch of
51 -    repetitious code, but its also simply not lazy, which is the real
52 +    repetitious code, but it's also simply not lazy, which is the real
53      tragedy.
54  
55      If you make your module a subclass of Class::Accessor and declare your