Added correct PATH and SBOX_REDIRECT_IGNORE and PERL5LIB envs in rules for libemail...
[pkg-perl] / deb-src / libemail-date-format-perl / libemail-date-format-perl-1.002 / debian / rules
1 #!/usr/bin/make -f
2 # This debian/rules file is provided as a template for normal perl
3 # packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
4 # the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
5 # be used freely wherever it is useful.
6
7 # Uncomment this to turn on verbose mode.
8 #export DH_VERBOSE=1
9
10 export SBOX_REDIRECT_IGNORE:=/usr/bin/perl
11 unexport PERL5LIB
12 export PATH:=/usr/bin/dh7:/usr/bin:$(PATH)
13
14 # If set to a true value then MakeMaker's prompt function will
15 # always return the default without waiting for user input.
16 export PERL_MM_USE_DEFAULT=1
17
18 PACKAGE=$(shell dh_listpackages)
19
20 ifndef PERL
21 PERL = /usr/bin/perl
22 endif
23
24 TMP     =$(CURDIR)/debian/$(PACKAGE)
25
26 build: build-stamp
27 build-stamp:
28         dh_testdir
29
30         # As this is a architecture independent package, we are not
31         # supposed to install stuff to /usr/lib. MakeMaker creates
32         # the dirs, we prevent this by setting the INSTALLVENDORARCH
33         # and VENDORARCHEXP environment variables.
34
35         # Add commands to compile the package here
36         $(PERL) Makefile.PL INSTALLDIRS=vendor \
37                 INSTALLVENDORARCH=/usr/share/perl5/ \
38                 VENDORARCHEXP=/usr/share/perl5/
39         $(MAKE)
40         $(MAKE) test
41
42         touch $@
43
44 clean:
45         dh_testdir
46         dh_testroot
47
48         dh_clean build-stamp install-stamp
49
50         # Add commands to clean up after the build process here
51         [ ! -f Makefile ] || $(MAKE) realclean
52
53 install: install-stamp
54 install-stamp: build-stamp
55         dh_testdir
56         dh_testroot
57         dh_clean -k
58
59         # Add commands to install the package into debian/$PACKAGE_NAME here
60         $(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
61
62         touch $@
63
64 binary-arch:
65 # We have nothing to do here for an architecture-independent package
66
67 binary-indep: build install
68         dh_testdir
69         dh_testroot
70         dh_installexamples
71         dh_installdocs README
72         dh_installchangelogs Changes
73         dh_perl
74         dh_compress
75         dh_fixperms
76         dh_installdeb
77         dh_gencontrol
78         dh_md5sums
79         dh_builddeb
80
81 source diff:
82         @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
83
84 binary: binary-indep binary-arch
85 .PHONY: build clean binary-indep binary-arch binary