16c48c5e0b71209669d8788d0c4db7f7f8f17a94
[pkg-perl] / deb-src / libfilter-perl / libfilter-perl-1.34 / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 tmp        = $(CURDIR)/debian/libfilter-perl
9 config     = INSTALLDIRS=vendor INSTALLMAN3DIR=/usr/share/man/man3
10 vendorarch = `perl -MConfig -e 'print $$Config{vendorarch}'`
11
12 configure: configure-stamp
13 configure-stamp:
14         dh_testdir
15         # Add here commands to configure the package.
16         perl Makefile.PL $(config)
17
18         touch configure-stamp
19
20 build: configure build-stamp
21 build-stamp:
22         dh_testdir
23
24         # Add here commands to compile the package.
25 ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
26         $(MAKE) OPTIMIZE="-O2 -g -Wall"
27 else
28         $(MAKE) OPTIMIZE="-g -Wall"
29 endif
30
31         touch build-stamp
32
33 clean: configure
34         dh_testdir
35         dh_testroot
36
37         # Add here commands to clean up after the build process.
38         [ ! -f Makefile ] || $(MAKE) realclean
39         rm -f Try.pm    # for 'make test'
40
41         dh_clean build-stamp configure-stamp
42
43 install: build
44         dh_testdir
45         dh_testroot
46         dh_clean -k
47         dh_installdirs
48
49         # Add here commands to install the package into debian/tmp.
50         $(MAKE) install PREFIX=$(tmp)/usr
51
52 # Build architecture-independent files here.
53 binary-indep: build install
54 # We have nothing to do by default.
55
56 # Build architecture-dependent files here.
57 binary-arch: build install
58         dh_testdir
59         dh_testroot
60         dh_installdocs
61         dh_installexamples
62         dh_installchangelogs Changes
63         dh_strip
64         dh_compress
65         dh_fixperms
66         dh_installdeb
67         dh_perl
68         dh_shlibdeps
69         dh_gencontrol
70         dh_md5sums
71         dh_builddeb
72
73 binary: binary-indep binary-arch
74 .PHONY: build clean binary-indep binary-arch binary install configure