Debian lenny version packages
[pkg-perl] / deb-src / libpar-dist-perl / libpar-dist-perl-0.31 / debian / rules
1 #!/usr/bin/make -f
2 # This debian/rules file is provided as a template for normal perl
3 # packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
4 # the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
5 # be used freely wherever it is useful.
6
7 # Uncomment this to turn on verbose mode.
8 #export DH_VERBOSE=1
9
10 # If set to a true value then MakeMaker's prompt function will
11 # always return the default without waiting for user input.
12 export PERL_MM_USE_DEFAULT=1
13
14 PERL   ?= /usr/bin/perl
15 PACKAGE = $(shell dh_listpackages)
16 TMP     = $(CURDIR)/debian/$(PACKAGE)
17
18 build: build-stamp
19 build-stamp:
20         dh_testdir
21         $(PERL) Makefile.PL INSTALLDIRS=vendor
22         $(MAKE)
23         PERL_TEST_POD=1 $(MAKE) test
24         touch $@
25
26 clean:
27         dh_testdir
28         dh_testroot
29         dh_clean build-stamp install-stamp
30         [ ! -f Makefile ] || $(MAKE) realclean
31
32 install: install-stamp
33 install-stamp: build-stamp
34         dh_testdir
35         dh_testroot
36         dh_clean -k
37         $(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
38         [ ! -d $(TMP)/usr/lib/perl5 ] || \
39                 rmdir --ignore-fail-on-non-empty --parents --verbose \
40                 $(TMP)/usr/lib/perl5
41         touch $@
42
43 binary-arch:
44 # We have nothing to do here for an architecture-independent package
45
46 binary-indep: build install
47         dh_testdir
48         dh_testroot
49         dh_installdocs
50         dh_installchangelogs Changes
51         dh_perl
52         dh_compress
53         dh_fixperms
54         dh_installdeb
55         dh_gencontrol
56         dh_md5sums
57         dh_builddeb
58
59 binary: binary-indep binary-arch
60 .PHONY: build clean binary-indep binary-arch binary install