Debian lenny version packages
[pkg-perl] / deb-src / libsub-uplevel-perl / libsub-uplevel-perl-0.1901 / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 # export DH_VERBOSE=1
7
8 include /usr/share/quilt/quilt.make
9
10 PACKAGE=$(shell dh_listpackages)
11 TMP=$(CURDIR)/debian/$(PACKAGE)
12
13 ifndef PERL
14 PERL = /usr/bin/perl
15 endif
16
17 build: build-stamp
18 build-stamp: $(QUILT_STAMPFN)
19         dh_testdir
20         $(PERL) Build.PL installdirs=vendor verbose=1
21         $(PERL) Build
22         # xt/spelling.t lacks Test::Spelling so we only take the other xt/ tests
23         $(PERL) Build test --test_files 't/*.t' --test_files 'xt/[cp]*.t'
24         touch $@
25
26 clean: unpatch
27         dh_testdir
28         dh_testroot
29         dh_clean build-stamp install-stamp
30         [ ! -f Build ] || $(PERL) Build distclean
31
32 install: install-stamp
33 install-stamp: build-stamp
34         dh_testdir
35         dh_testroot
36         dh_clean -k
37         $(PERL) Build install destdir=$(TMP) create_packlist=0
38         touch $@
39
40 binary-arch:;
41 binary-indep: build install
42         dh_testdir
43         dh_testroot
44         dh_installdocs
45         dh_installexamples examples/*
46         dh_installchangelogs Changes
47         dh_compress
48         dh_fixperms
49         dh_installdeb
50         dh_perl
51         dh_gencontrol
52         dh_md5sums
53         dh_builddeb
54
55 binary: binary-indep binary-arch
56 .PHONY: build clean binary-indep binary-arch binary install configure