Add the following packages libalgorithm-diff-perl libspiffy-perl libtext-diff-perl...
[pkg-perl] / deb-src / libtest-base-perl / libtest-base-perl-0.54 / debian / control
1 Source: libtest-base-perl
2 Section: perl
3 Priority: optional
4 Build-Depends: debhelper7
5 Build-Depends-Indep: perl (>= 5.6), libspiffy-perl (>= 0.30),
6  libtest-simple-perl (>= 0.62), libalgorithm-diff-perl, libtext-diff-perl,
7  libyaml-perl
8 Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
9 Uploaders: Florian Ragwitz <rafl@debian.org>, Damyan Ivanov <dmn@debian.org>
10 Standards-Version: 3.8.0
11 Homepage: http://search.cpan.org/dist/Test-Base/
12 Vcs-Svn: svn://svn.debian.org/pkg-perl/trunk/libtest-base-perl/
13 Vcs-Browser: http://svn.debian.org/wsvn/pkg-perl/trunk/libtest-base-perl/
14
15 Package: libtest-base-perl
16 Architecture: all
17 Depends: ${perl:Depends}, libspiffy-perl (>= 0.30), libalgorithm-diff-perl, libtext-diff-perl, libtest-simple-perl (>= 0.6.2)
18 Description: A data driven testing framework for Perl
19  Testing is usually the ugly part of Perl module authoring. Perl gives you a
20  standard way to run tests with Test::Harness, and basic testing primitives
21  with Test::More. After that you are pretty much on your own to develop a
22  testing framework and philosophy. Test::More encourages you to make your own
23  framework by subclassing Test::Builder, but that is not trivial.
24  .
25  Test::Base gives you a way to write your own test framework base class that is
26  trivial. In fact it is as simple as two lines:
27    package MyTestFramework;
28    use Test::Base -Base;
29  .
30  A module called MyTestFramework.pm containing those two lines, will give all
31  the power of Test::More and all the power of Test::Base to every test file
32  that uses it. As you build up the capabilities of MyTestFramework, your tests
33  will have all of that power as well.
34  .
35  MyTestFramework becomes a place for you to put all of your reusable testing
36  bits. As you write tests, you will see patterns and duplication, and you can
37  "upstream" them into MyTestFramework. Of course, you don't have to subclass
38  Test::Base at all. You can use it directly in many applications, including
39  everywhere you would use Test::More.
40  .
41  Test::Base concentrates on offering reusable data driven patterns, so that you
42  can write tests with a minimum of code. At the heart of all testing you have
43  inputs, processes and expected outputs. Test::Base provides some clean ways
44  for you to express your input and expected output data, so you can spend your
45  time focusing on that rather than your code scaffolding.