Remove tests
[pkg-perl] / deb-src / libtest-differences-perl / libtest-differences-perl-0.47 / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 export SBOX_REDIRECT_IGNORE:=/usr/bin/perl
9 unexport PERL5LIB
10 export PATH:=/usr/bin/dh7:/usr/bin:$(PATH)
11
12 # This is the debhelper compatibility version to use.
13 # export DH_COMPAT=4
14
15 PACKAGE=`pwd | sed -e "s/.*\/\\(.*\\)-.*/\\1/"`
16
17
18 build:
19         dh_testdir
20         # Add here commands to compile the package.
21         perl Makefile.PL verbose INSTALLDIRS=vendor
22 clean:
23         dh_testdir
24         dh_testroot
25
26         -$(MAKE) clean
27         rm -f Makefile.old
28         dh_clean
29
30 install:
31         dh_testdir
32         dh_testroot
33         dh_clean -k
34         dh_installdirs
35
36         $(MAKE) PREFIX=$(CURDIR)/debian/$(PACKAGE)/usr OPTIMIZE="-O2 -g -Wall" test install
37         -find $(CURDIR)/debian -type d | xargs rmdir -p --ignore-fail-on-non-empty
38
39 binary-arch:;
40 binary-indep: build install
41         dh_testdir
42         dh_testroot
43         dh_installdocs
44         dh_installman
45         dh_installchangelogs Changes
46         dh_link
47         dh_strip
48         dh_compress
49         dh_fixperms
50         dh_installdeb
51         dh_perl
52         dh_gencontrol
53         dh_md5sums
54         dh_builddeb
55
56 binary: binary-indep binary-arch
57 .PHONY: build clean binary-indep binary-arch binary install configure