Debian lenny version packages
[pkg-perl] / deb-src / libwww-mechanize-perl / libwww-mechanize-perl-1.34 / debian / patches / no_internet.patch
1 Index: libwww-mechanize-perl/t/live/computers4sure.t
2 ===================================================================
3 --- libwww-mechanize-perl.orig/t/live/computers4sure.t  2007-12-01 18:12:17.000000000 -0600
4 +++ libwww-mechanize-perl/t/live/computers4sure.t       2007-12-01 18:16:55.000000000 -0600
5 @@ -3,6 +3,10 @@
6  use warnings;
7  use strict;
8  
9 +if ($ENV{NOINTERNET} ) {
10 +   use Test::More skip_all => "We don't have internet here";
11 +}
12 +
13  use Test::More skip_all => 'Still need to get the error-handling on here working';
14  use Test::More tests => 9;
15  
16 Index: libwww-mechanize-perl/t/live/wikipedia.t
17 ===================================================================
18 --- libwww-mechanize-perl.orig/t/live/wikipedia.t       2007-12-01 18:12:17.000000000 -0600
19 +++ libwww-mechanize-perl/t/live/wikipedia.t    2007-12-01 18:17:12.000000000 -0600
20 @@ -3,6 +3,11 @@
21  use warnings;
22  use strict;
23  
24 +if ($ENV{NOINTERNET} ) {
25 +   use Test::More skip_all => "We don't have internet here";
26 +}
27 +
28 +
29  use constant LANGUAGES => qw( en it ja es nl pl );
30  use Test::More tests => 3 + (2 * scalar LANGUAGES);
31