3f00b08e7a5f4dc4b9d10f966195d31855b84d3a
[pkg-perl] / deb-src / libwww-perl / libwww-perl-5.813 / debian / rules
1 #!/usr/bin/make -f
2 # This debian/rules file is provided as a template for normal perl
3 # packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
4 # the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
5 # be used freely wherever it is useful.
6
7 # Uncomment this to turn on verbose mode.
8 #export DH_VERBOSE=1
9
10 # If set to a true value then MakeMaker's prompt function will
11 # always return the default without waiting for user input.
12 export PERL_MM_USE_DEFAULT=1
13
14 PERL   ?= /usr/bin/perl
15 PACKAGE = $(shell dh_listpackages)
16 TMP     = $(CURDIR)/debian/$(PACKAGE)
17
18 build: build-stamp
19 build-stamp:
20         dh_testdir
21         $(PERL) Makefile.PL INSTALLDIRS=vendor
22         $(MAKE)
23         # Turn off the live checks
24         if [ -f t/live/ENABLED ]; then rm t/live/ENABLED; fi
25         if [ -f t/live/ZLIB_OK ]; then rm t/live/ZLIB_OK; fi
26         $(MAKE) test
27         touch $@
28
29 clean:
30         dh_testdir
31         dh_testroot
32         dh_clean build-stamp install-stamp
33         [ ! -f Makefile ] || $(MAKE) realclean
34
35 install: install-stamp
36 install-stamp: build-stamp
37         dh_testdir
38         dh_testroot
39         dh_clean -k
40         $(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
41         [ ! -d $(TMP)/usr/lib/perl5 ] || \
42                 rmdir --ignore-fail-on-non-empty --parents --verbose \
43                 $(TMP)/usr/lib/perl5
44         touch $@
45
46 binary-arch:
47 # We have nothing to do here for an architecture-independent package
48
49 binary-indep: build install
50         dh_testdir
51         dh_testroot
52         dh_installdocs README README.SSL
53         dh_installchangelogs Changes
54         dh_link
55         dh_perl
56         dh_compress
57         dh_fixperms
58         dh_installdeb
59         dh_gencontrol
60         dh_md5sums
61         dh_builddeb
62
63 binary: binary-indep binary-arch
64 .PHONY: build clean binary-indep binary-arch binary install