f16ce04944d6bff7641d2b588c5c26d76b32b305
[ussd-widget] / ussd4all / debian / rules
1 #!/usr/bin/make -f
2 APPNAME := ussd4all
3 builddir:
4         mkdir -p builddir
5
6 builddir/Makefile: builddir
7         cd builddir && qmake-qt4 PREFIX=/usr ../$(APPNAME).pro
8
9 build: build-stamp
10
11 build-stamp: builddir/Makefile
12         dh_testdir
13         # Add here commands to compile the package.
14         cd builddir && $(MAKE)
15         touch $@
16
17 clean:
18         dh_testdir
19         dh_testroot
20         rm -f build-stamp
21         # Add here commands to clean up after the build process.
22         rm -rf builddir
23         dh_clean
24 install: build
25         dh_testdir
26         dh_testroot
27         dh_clean -k
28         dh_installdirs
29
30         # Add here commands to install the package into debian/your_appname
31         cd builddir && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
32
33         mkdir -p "$(CURDIR)/debian/ussd4all/usr/lib/python2.5/"
34         cp -a "ussdquery/gsmdecode.py" "$(CURDIR)/debian/ussd4all/usr/lib/python2.5/gsmdecode.py"
35         mkdir -p "$(CURDIR)/debian/ussd4all/usr/bin/"
36         cp -a "ussdquery/ussdquery.py" "$(CURDIR)/debian/ussd4all/usr/bin/ussdquery.py"
37
38 # Build architecture-independent files here.
39 binary-indep: build install
40 # We have nothing to do by default.
41
42 # Build architecture-dependent files here.
43 binary-arch: build install
44         dh_testdir
45         dh_testroot
46         dh_installdocs
47         dh_installexamples
48         dh_installman
49         dh_link
50         dh_strip --dbg-package=my-application-dbg
51         dh_compress
52         dh_fixperms
53         dh_installdeb
54         dh_shlibdeps
55         dh_gencontrol
56         dh_md5sums
57         dh_builddeb
58         
59 binary: binary-indep binary-arch
60 .PHONY: build clean binary-indep binary-arch binary install configure